ブロとも申請 全記事一覧

スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

パッチ「openSUSE-2011-5」アップデートの競合エラー

Apper(更新マネージャー)を使ってアップデートしようとすると
パッチ「openSUSE-2011-5」だけ、エラーとなりアップデートできませんでした。

今回はその対処方法をご紹介します、、、

<問題>
Apper(更新マネージャー)で表示されるパッチ「openSUSE-2011-5」を適用しようとすると
gstreamer のパッケージ競合による依存性エラーとなり、適用できない。

err_update_gstreamer01.png

err_update_gstreamer02.png



<方法>
1.KDE システム設定を起動する。

2.システム管理 > Software Management を選択する。
err_update_gstreamer11.png


3.Lists > Installed Software を選択する。
err_update_gstreamer12.png


4.パッケージ名「gstreamer-0_10-fluendo-mp3」で検索する。

5.「gstreamer-0_10-fluendo-mp3」パッケージの最新バージョン(ここでは 12-8.1)のインストールボタンを押下し、「適用」ボタンを押下する。
err_update_gstreamer13.png


6.インストールするパッケージ内容、アップグレード内容を確認し「続行」ボタンを押下する。
err_update_gstreamer14.png

err_update_gstreamer15.png


7.root ユーザーのパスワードを入力し「OK」ボタンを押下する。
err_update_gstreamer16.png


8.ライセンス内容を確認し、「承諾を受け入れる」ボタンを押下する。
err_update_gstreamer17.png


9.インストール完了後、手順3の画面で Lists > Updates を選択する。

10.適用できなかったパッチが更新リストに表示されないことを確認する。
err_update_gstreamer18.png


以上です。
競合していたパッケージを手動でアップグレードしてやることで対処できました。

今回は 11.4 > 12.1 にアップグレードした直後だったためこのような事象が発生したと思いますが、通常は、このような競合エラーはでないと思います。

もし、同様のエラーが発生した際は、エラーメッセージを確認し、その状況に応じた対応を行ってみてください。

テーマ : Linux
ジャンル : コンピュータ

tag : openSUSE 12.1 アップデート エラー

コメントの投稿

管理者にだけ表示を許可する

ブログを購読する
プロフィール

Red456

ブロガー:Red456

最新情報

Red456_openSUSEをフォローしましょう
openSUSE 関連サイト
お気に入りのサイト
カテゴリ
NAS (1)
NFS (1)
カレンダー
10 | 2017/11 | 12
- - - 1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30 - -
最新コメント
アクセス数
タグクラウド


上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。